Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
ринат126
16.08.2022 19:48 •
Информатика
Задайте массив из 10 элементов с датчика случайных чисел. все элементы, которые больше 55 замените максимальным
Ответ:
Rarete
14.08.2020 08:50
Program prog;
uses crt;
var a: array [1..10] of integer;
i, max: integer;
begin
clrscr;
randomize;
max:=0;
for i:=1 to 10 do
begin;
a[i]:= random(100);
if a[i]>max then max:=a[i];
writeln('a[',i,'] = ', a[i]);
end;
writeln;
for i:=1 to 10 do
begin;
if a[i]>55 then a[i]:=max;
writeln('a[',i,'] = ', a[i]);
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
SeamCard
31.10.2022 01:15
Напиши название диалоговых окон и их применение...
dodpddpfp
09.06.2021 21:04
14103(ea3) перевести из шестнадцатиричной в десятичную систему....
sandraustaow6o7c
15.03.2022 04:13
Информатика 9 класс Массивы в Pascal...
5Vlad2851
08.10.2021 04:50
БоОоТт ззнАаНннИи ТееЕЛЛЛеГГграАМм - @united brai nly (бееЗЗз ППпРроООБББЕеЛовв)...
vikasamartseva1
23.06.2021 20:40
ББбООТт ЗЗИи ТТТЕлЕееГГгрРаам - @united brai nly (БББзз пПЕЕллЛОоВв)...
1234мика
09.08.2022 10:01
Задача: найти значение максимального элемента в одномерном массиве, который заполняется случайными числами....
darinanugmanova
12.02.2023 19:09
3. Дан словарь, в котором ключи – названия месяца, а значения – объем осадков за месяц. Необходимо отсортировать месяцы по возрастанию количества осадков. Язык Питон...
564444
03.04.2022 02:03
В алфавите папуасов содержится 3 буквы из папуасов составили слова из 5 букв определите максимальное возможное количество составленных слов решить...
milena7772
15.02.2022 14:10
ББОоТ ЗзнннАнНнИиИЯя теЕеллеерррмМ - @united brai nly (Ббеезз ппрРрОбблЛОоОВв)...
rmaro82
25.01.2022 16:05
У каво нибуть есть фаил с ответом на данную работу скиньте...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
uses crt;
var a: array [1..10] of integer;
i, max: integer;
begin
clrscr;
randomize;
max:=0;
for i:=1 to 10 do
begin;
a[i]:= random(100);
if a[i]>max then max:=a[i];
writeln('a[',i,'] = ', a[i]);
end;
writeln;
for i:=1 to 10 do
begin;
if a[i]>55 then a[i]:=max;
writeln('a[',i,'] = ', a[i]);
end;
end.