В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Нужно составить программу которая находит площадь и периметр поямоугольника 2)составте программу для вычисления косинусов углов треугольника со старонами а,в,с

Ответ:
danier2
danier2
14.08.2020 07:56
Var
    a, b: real;

begin
    readln(a, b);
    writeln('P = ', 2 * (a + b));
    writeln('S = ', a * b);
end.

2)
var
    a, b, c: real;

begin
    readln(a, b, c);
    writeln('cos(alpha) = ', (b * b + c * c - a * a) / (2 * b * c));
    writeln('cos(beta) = ', (a * a + c * c - b * b) / (2 * a * c));
    writeln('cos(gamma) = ', (a * a + b * b - c * c) / (2 * a * b));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?