В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
dnlnv
dnlnv
17.07.2022 22:02 •  Информатика

Составить программу для паскаля.1)определить количество трехзначных чисел сума цифр которых равна числу n.2)дано натуральное число n.составить программу меняющихся местами первую и последнюю цифру.

Ответ:
haikyuu24
haikyuu24
03.10.2020 20:56
1)
var  s: string;
  i, n,c: integer;
begin
  read(n);
  for i := 100 to 999 do
  begin
    s:=inttostr(i);
    c:=(strtoint(s[1])+strtoint(s[2])+strtoint(s[3]));
    if(n=c)then writeln(s);
  end;
end.

2)
var  s: string;
begin
  read(s);
  swap(s[1],s[s.Length]);
  write(s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?