В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

:вы ввели трехзначное число. составьте программу, определяющую, есть ли в этом числе, четные цифры. вопрос: в какой программе решается данная и каким образом?

Ответ:
bcfujd19
bcfujd19
30.09.2020 04:21
Лучше всего сделать в pascal. 
Попробуй этот код:
var  n: integer;  boo: boolean;begin  write('Введите число: ');  readln(n);  boo:=odd(n);  case boo of     true: writeln('Нечетное');    false: writeln('Четное');  end;  readln;end.
0,0(0 оценок)
Ответ:
123456445
123456445
30.09.2020 04:21
Program OddNumeric;
var
  n, i: integer;
  a: array [1..3] of byte;
  b: boolean;
begin
  Write('Введите трехзначное число: ');
  Readln(n);
  a[1]:=n div 100; {1 цифра сотен}
  a[2]:=(n div 10) mod 10; {2 цифра десятков}
  a[3]:=n mod 10; {3 цифра количество единиц}
  b:=false;
  for i:=1 to 3 do
  begin
     if (a[i] mod 2)=0 then
         b:=true;
  end;
  if b then
   Writeln('В этом числе есть четные цифры')
  else
     Writeln('В этом числе нет четных цифр');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?