В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Маришка1231
Маришка1231
03.01.2022 12:49 •  Информатика

Программирование на языке си! любую из этих программ: 1. составить программу, которая определяет произведение цифр четырехзначного числа, введенного пользователем. 2составить программу, которая запрашивает у пользователя целочисленные корни многочлена четвертой степени и, используя теорему виета, находит его коэффициенты. вывести результат в форме таблицы, где первая строка – степени, а вторая – коэффициента при этих степенях.

Ответ:
marina19793
marina19793
29.09.2020 22:23
1. #include <stdio.h>#include <ctype.h>
int main(int argc, char** argv){    char a, b, c, d;    if (scanf("%c%c%c%c", &a, &b, &c, &d) != 4)        printf("Input error\n");    else    {        if (isdigit(a) && isdigit(b) && isdigit(c) && isdigit(d) && (a > '0'))            printf("Sum is %d\n", a + b + c + d - 4 * '0');        else            printf("Is itn't correct number\n");    }    return 0;}
0,0(0 оценок)
Ответ:
Alinatkd
Alinatkd
29.09.2020 22:23
1. Программа (без проверки правильности ввода):
#include <stdio.h> 

int main() 

   int N;
   scanf ("%d", &N); 
   int sum; 
   sum = N/1000 + N/100%10 + N%100/10 + N%10;
   printf ("sum = %d",sum);
}

Пример:
5029
sum = 16
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?