В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Волна1610
Волна1610
31.08.2021 10:40 •  Информатика

Написать программу, которая вычисляет среднее арифметическое ненулевых элементов введенного с клавиатуры массива целых чисел. ниже рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом). введите элементы массива (10 целых чисел) в одной строке и нажмите . -> 23 0 45 -5 12 0 -2 30 0 64 сумма элементов массива: 184 кол-во ненулевых элементов: 7 среднее арифметическое ненулевых элементов: 23.86

Ответ:
17834567
17834567
28.05.2020 19:02

var mas:array[1..10] of integer;

   i,kolvo:integer;

   b:real;

   

begin

writeln('Введите 10 целых чисел: ');

for i:=1 to 10 do

begin

read(mas[i]);

kolvo:= kolvo+1;

if (mas[i]=0) then kolvo:= kolvo-1;

end;

 

for i:=1 to 10 do  

begin

b:=mas[i] + b;

end;

 

b:= b/kolvo;

 

writeln('Количество ненулевых чисел= ', kolvo);

writeln('Среднее арифметическое ненулевых чисел= ', b);

 

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?