В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
sweetk
sweetk
08.11.2021 11:24 •  Информатика

Напишите программу на языке паскаль.богатый и бедный заключили спор .богатый отдает каждый день 100 в течение месяца .бедный отдает в первый день копейку каждый следующий день в 2 раза больше в течение месяца ,кто выграет спор

Ответ:
nastyapuhova1
nastyapuhova1
29.09.2020 11:58
Var m1,m2,st,i:integer;
begin
m1:=0; m2:=0;
st:=1;
for i:=1 to 30 do
 begin
 m1:=m1+100;
 m2:=m2+st;
 st:=st*2;
 end;
writeln('Богатый: ',m1,'  бедный: ',m2);
if m1<m2 
 then writeln('Выиграл богатый') else writeln('Выиграл бедный');
end.

Результат:
Богатый: 3000  бедный: 1073741823
Выиграл богатый
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?