В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
0502abylai
0502abylai
16.05.2021 14:57 •  Информатика

Паскаль как написать программу, которая уменьшала бы все максимальные элементы в два раза? так? max: =a[1,1]; if a[i,j] > max then max: = a[i,j]; end; max: = max div 2; просто в данном случае, уменьшает только один максимальный элемент и то не всегда выдает правильный ответ.(делю квадратную матрицу 2*2 с элементами: 2 4 6 8 выводит max=2)

Ответ:
Инна1234432114865
Инна1234432114865
02.08.2020 01:58
Const m=4; n=5;
var 
a:array[1..m,1..n] of real;
i,j:integer; max:real;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to m do
 begin
 for j:=1 to n do
  begin
   a[i,j]:=random(10);
   write(a[i,j]:5:1);
  end;
  writeln;
 end;
max:=a[1,1];
for i:=1 to m do
 for j:=1 to n do
  if a[i,j]>max then max:=a[i,j];
writeln('max = ',max);
for i:=1 to m do
 for j:=1 to n do
  if a[i,j]=max then a[i,j]:=a[i,j]/2;
writeln('Полученный массив:');
for i:=1 to m do
 begin
 for j:=1 to n do write(a[i,j]:5:1);
 writeln;
 end;
end.

Пример:
Исходный массив:
  1.0  9.0  1.0  9.0  8.0
  4.0  4.0  5.0  9.0  9.0
  6.0  3.0  6.0  0.0  6.0
  6.0  7.0  3.0  6.0  9.0
max = 9
Полученный массив:
  1.0  4.5  1.0  4.5  8.0
  4.0  4.0  5.0  4.5  4.5
  6.0  3.0  6.0  0.0  6.0
  6.0  7.0  3.0  6.0  4.5
0,0(0 оценок)
Ответ:
ryschowa
ryschowa
02.08.2020 01:58
Судя по всему вы понимаете, поэтому подсказки будет достаточно. Немного не так. Вы не сдвигаете элемента массива. Вам нужен отдельные циклы для увеличения i и j. Тогда программа будет сама переходить к нужному элементу массива на каждой итерации.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?