В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
provotorov2001
provotorov2001
25.03.2020 01:53 •  Информатика

Нужно написать программу, в которой будет выводиться сумма всех чисел, в которых есть повторяющиеся цифры (например 22,33,44,100,101,202,110,202 и т.д). так до можете хоть на паскале, где угодно. только укажите в своем ответе программу, на которой писали.

Ответ:
mchizhevskayap010bm
mchizhevskayap010bm
03.10.2020 19:56
Программа на паскале:
var a,c,s:integer;
m:set of 0..9;
b:boolean;
begin
s:=0;
for a:=10 to 10000 do
 begin
 m:=[];
 b:=false;
 c:=a;
 while c<>0 do
  begin
  if (c mod 10) in m then b:=true;
  m:=m+[c mod 10];
  c:=c div 10;
  end;
 if b then s:=s+a;
 end;
writeln('s = ',s);
end.

Результат:
s = 24727105
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?