В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Svetakim0934
Svetakim0934
03.12.2021 10:48 •  Информатика

Написать программу в паскале вводим число, проверить извлекается из него корень?

Ответ:
olgaaaaaa13
olgaaaaaa13
03.10.2020 19:15
Var a,b:integer;
begin
write('a = ');
readln(a);
b:=round(sqrt(a));
if b*b=a
 then writeln('Yes, ',b,' * ',b,' = ',a)
 else writeln('No');
end.

Пример 1:
a = 289
Yes, 17 * 17 = 289

Пример 2:
a = 250
No
0,0(0 оценок)
Ответ:
МарысяДэн
МарысяДэн
03.10.2020 19:15
Гарантируется правильная работа программы при вводе натуральных чисел, не превышающих 9 223 372 030 926 249 001

var
  i,n,m:int64;
begin
  Write('Вводите: ');
  Read(m);
  n:=0;
  for i:=1 to m div 2 do
    begin
      n:=n+2*i-1;
      if (n>=m) then break
    end;
  if n=m then Writeln('Кв.корень(',m,')=',i)
  else Writeln('Кв.корень(',m,') не является целочисленным')
end.

Примеры работы программы

Вводите: 255240500157504
Кв.корень(255240500157504)=15976248

Вводите: 225
Кв.корень(225)=15

Вводите: 56846356333463
Кв.корень(56846356333463) не является целочисленным

Вводите: 9223372030926249001
Кв.корень(9223372030926249001)=3037000499
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?