В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
shitova20023p02gai
shitova20023p02gai
29.12.2022 21:13 •  Информатика

Составить программу на free pascal. дано натуральное число. верно ли, что произведение его цифр не больше 50

Ответ:
Brainly2233
Brainly2233
08.09.2020 01:35
Если число не слишком большое, то:
var n,p:integer;
begin
write('n = ');
readln(n);
p:=1;
while n>0 do
 begin
 p:=p*(n mod 10);
 n:=n div 10;
 end;
if p<=50
 then writeln('Произведение цифр числа = ',p,' (<= 50)')
 else writeln('Произведение цифр числа = ',p,' (> 50)');
end.

Пример:
n = 456
Произведение цифр числа = 120 (> 50)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?