В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Составьте программу для решения двух квадратных уравнений используя процедуру решения квадратного уравнения​

Ответ:
ruuuuuyslan
ruuuuuyslan
28.05.2020 17:03

Var a,b,c,d,x1,x2: real;

Begin

Clrscr;

Write('введите коэффициенты уравнения a,b,c'); readln(a,b,c);

D:=b*b-4*a*c;

If d>=0 then

Begin

X1:=(-b+sqrt(d))/(2*a); x2:=(-b-sqrt(d))/(2*a);

Writeln('x1=',x1' x2=',x2)

END;

Else writeln('действительных корней нет')

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?