Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
bektemirova1
23.10.2020 07:38 •
Информатика
Дан массив числе а(n). найти sra положительных элементов и sg отрицательных элементов
Ответ:
Anopsis
03.10.2020 18:53
//Pascal ABC.NET 3.1 сборка 1256
Const
n=5;
begin
var a:=ReadArrInteger(n);
var Sra:=a.where(x -> x>0).Count;
writeln('Положительных:',Sra);
var Sg:=a.Where(x -> x<0).Count;
writeln('Отрицательных:',Sg);
end.
Пример ввода:
-1
1
-2
2
3
Пример вывода:
Положительных:3
Отрицательных:2
0,0
(0 оценок)
Популярные вопросы: Информатика
BooHazz
07.05.2023 22:59
Как известно, в самолете часто предлагают горячий обед во время длительного перелета. Маленькой Варе скоро предстоит путешествие, поэтому ей интересно узнать, сколько...
AMINA2007133456
19.10.2020 03:08
Решите задачу на тему: Логика...
ROUSWOOD
12.07.2021 01:00
Напишите программу на python, которая производит обмен значений переменных x и y, если x больше y. Пример входных данных Пример выходных данных Введите x 5 x = 5...
34Марго35
07.09.2021 15:45
Текст задания: В нашей новой игре подводная лодка должна вернуться на базу, где бы она ни находилась. Напиши код для лодки так, чтобы она вернулась на базу с любой...
peterDIYanov
01.11.2020 15:53
Дана строка содержащая слово записанное через дефис написать программу определяющую позицию дефиса...
DashaBudlevskaya
23.02.2023 05:14
Ввести число. Если оно четное, разделить его на 3, если нечётное - умножить на 5. Питон...
54783
13.01.2020 22:34
Расположите графические редакторы в порядке возрастания их функциональных возможностей: 1) аниматор 2)paint 3) coreldraw...
sudarev2018
30.03.2021 02:55
Логические устройства эвм проектируются на основе аппарата 1реляционной 2теории графов 3аналитической 4булевой...
mariyapetrpet
17.12.2021 17:13
Составьте программу вычисления произведения элементов матрицы b(n,n),кратных 3. турбо паскаль...
tkalichzhenya
25.01.2020 02:15
Решить неравенства: Ctgx = -√3/3; sinx =√3/2...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Const
n=5;
begin
var a:=ReadArrInteger(n);
var Sra:=a.where(x -> x>0).Count;
writeln('Положительных:',Sra);
var Sg:=a.Where(x -> x<0).Count;
writeln('Отрицательных:',Sg);
end.
Пример ввода:
-1
1
-2
2
3
Пример вывода:
Положительных:3
Отрицательных:2