В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
andreykolomoytsev
andreykolomoytsev
31.10.2022 14:36 •  Информатика

Мне нужно ответь составить программу, которая бы запрашивала хнач , хкон , шаг c и определяла сумму всех отрицательных чисел от хнач до хкон с шагом с (решить , используя цикл с постусло-вием – repeat … until).

Ответ:
POLINAzhavoronkova
POLINAzhavoronkova
03.10.2020 18:47
//Pascal ABC.NET 3.1 сборка 1256

Var
 n,k,c,s,kar:real;
 i:integer;
begin
read(n,k,c);
i:=0;
s:=0;
kar:=n;
repeat
if n<0 then s:=s+n;
inc(i);
n:=kar+i*c;
until n>k;
writeln(s);
end.

Пример ввода:
-3
1
1.1
Пример вывода:
-5.7

Мне нужно ответь составить программу, которая бы запрашивала хнач , хкон , шаг c и определяла сумму
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?