Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
hchv
14.02.2022 14:48 •
Информатика
Pascal.дана последовательность чисел .вывести на экран суммы положительных и отрицательных чисел данной последовательности.
Ответ:
Dasha8999
03.10.2020 18:42
//Pascal ABC.NET 3.1 сборка 1219
Const
n=10;
Begin
var ar:=ReadArrInteger(n);
writeln('Сумма положительных=',ar.Where(x -> x>0).sum);
writeln('Сумма сумма отрицательных=',ar.Where(x -> x<0).sum);
end.
Пример ввода:
1
-2
3
4
-5
-6
7
8
9
10
Пример вывода:
Сумма положительных=42
Сумма сумма отрицательных=-13
0,0
(0 оценок)
Популярные вопросы: Информатика
RichiMcRothschild
03.12.2022 07:47
Петя и вася игрунковы любят играть в стрелялки. на начальном этапе у них по 10 патронов на брата. вася уже успел потратить некоторое количество патронов. а петя...
darkelan
03.12.2022 07:47
Была получена телеграмма встречайте, вагон 4 . известно, что в составе поезда 8 вагонов.: какое количество информации было получено?...
mmsh19
04.06.2022 06:34
Напишите программу на паскаль с массива. я знаю что там должно быть написано со словом array. напишите программу для решения следующей задачи. на контрольной...
ZHICH
28.05.2020 16:35
Система счисления записано число в развернутой форме: а*161 + 160 + 7*16-1 + 5*16-2 =...
CuprumJewellier5
03.04.2020 15:11
Что означает этот знак? на задней стороне монитора...
Бесконечноенебо
13.02.2020 20:50
Нужно решить в паскале используя цикл. номер 1 , 2 или 5...
oroz9898
05.09.2021 19:49
Дан алгоритм в виде блок-схемы. запишите его на алгоритмическом языке....
е7гроошишгини
14.04.2023 10:32
На уроке труда смастерили электронную доску 5*5. после включения через секунду засвечивается центральный квадратик, а через каждую новую секунду засвечиваются квадратики...
alexstasy
19.01.2022 15:50
Составьте программу рисования узора местоположение робота отмечено ромбом.кр1. 3 использование циклов при создании орнаментов 1 вариант....
kaba4ok2001
25.03.2020 11:36
Решите ! символьная строка длиной 100 закодировано при двух алфавитов мощность: первого равна 8, мощность второго 64. определите количество информации в тексте,...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Const
n=10;
Begin
var ar:=ReadArrInteger(n);
writeln('Сумма положительных=',ar.Where(x -> x>0).sum);
writeln('Сумма сумма отрицательных=',ar.Where(x -> x<0).sum);
end.
Пример ввода:
1
-2
3
4
-5
-6
7
8
9
10
Пример вывода:
Сумма положительных=42
Сумма сумма отрицательных=-13