В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
VadimButs
VadimButs
09.12.2021 02:06 •  Информатика

Pascal. напишите программу ,которая из заданной строки удаляет числа.

Ответ:
ivolapseb
ivolapseb
28.09.2020 17:30
//Сомнительный метод, но почему бы и нет?
//Pascal ABC.NET 3.1 сборка 1219

Var
 s,s1:string;
 se:set of char;
 i:integer;
begin
se:=['0','1','2','3','4','5','6','7','8','9'];
readln(s);
for i:=1 to length(s) do
if not(s[i] in se) then s1:=s1+s[i];
s:=s1;
writeln(s);
end. 

Пример ввода:
S0me I3or1ng Text
Пример вывода:
Sme Iorng Text
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?