В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ириша182300
ириша182300
25.09.2022 00:11 •  Информатика

Написать программу в с ++ составить программу обработки матрицы размерности n*m. выполнить программу для n=3,m=4.заполнение массива произвести с датчика случайных чисел. в программе предусмотреть вывод исходной матрицы и полученной. по невозрастанию значений небольших элементов строк.( упорядочить(переставить)столбцы массива)

Ответ:
sane08one
sane08one
03.10.2020 18:50
//Dev-C++ 4.9.9.2

#include <ctime>
#include <iostream>
using namespace std;

#define n 3
#define m 4

int main(){
    srand(time(NULL));
    int ma[n][m];
    int arsub[n];
    int max=-1;
    cout<<"Matrix:"<<endl;
    for(int i=0;i<n;i++){
            for(int j=0;j<m;j++){
                    ma[i][j]=rand()%50;
                    cout<<ma[i][j]<<' ';
                    if(ma[i][j]>max)max=ma[i][j];}
            cout<<endl;
            arsub[i]=max;
            max=-1;}
    for(int i=0;i<n-1;i++)
     for(int j=i+1;j<n;j++)
                    if(arsub[j]>arsub[i]){
                     for(int z=0;z<m;z++)
                     swap(ma[i][z],ma[j][z]);
                     swap(arsub[j],arsub[i]);}
     cout<<"Final matrix:"<<endl;
        for(int i=0;i<n;i++){
            for(int j=0;j<m;j++)
                    cout<<ma[i][j]<<' ';
            cout<<endl;}
     cin.get();
     cin.get();
  return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?