В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mr7ka
mr7ka
07.03.2020 12:05 •  Информатика

Вdelphi. составить программу для нахождения суммы: 2! +3! +4! ++n!

Ответ:
Thanks2y
Thanks2y
03.10.2020 18:39
//Создать консольное приложение
program ConsoleProgram; 
{$APPTYPE CONSOLE}
var valueN,sum,i,i2,tmp:longint;
begin
sum:=0;
readln(valueN);
for i:=1 to valueN do
begin
tmp:=1;
for i2:=1 to i do
tmp:=tmp*i2;
sum:=sum+tmp;
end;
writeln(sum);
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?