В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
revunova
revunova
09.02.2022 14:35 •  Информатика

Составить программу для вычисления произведения отрицательных элементов массива а=(а1,а2,,…,аn). например: а=(-2,6,8,-45,0,23,5,43,-8)

Ответ:
Аминка233
Аминка233
28.09.2020 16:24
//Pascal ABC.NET 3.1 сборка 1219

Const
 n=10;

Var
 ar:array[1..n] of integer;
 i,p:int64;
begin
 randomize;
 p:=1;
 writeln('Array:');
 for i:=1 to n do
  begin
   ar[i]:=random(-10,10);
   write(ar[i]:4);
   if ar[i]<0 then p:=p*ar[i];
  end;
 writeln;
 write('Res:',p);
end.

Пример работы программы:
Array:
  -4  -9  -6   3   6   2  -3   0  -9  -3
Res:17496
0,0(0 оценок)
Ответ:
Mar09
Mar09
28.09.2020 16:24
// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
begin
  var a:=ReadArrInteger(ReadInteger('n='));
  Writeln('Произведение отрицательных: ',
    a.Where(x->x<0).Aggregate(BigInteger(1),(x,p)->x*p))
end.

Тестовое решение
n= 9
-2 6 8 -45 0 23 5 43 -8
Произведение отрицательных: -720
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?