В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Оля142768
Оля142768
31.10.2020 05:02 •  Информатика

Сильно на языке pascalabc.net или turbopascal: 1) разработать программу циклической структурой,используя цикл с параметром. дано действительное число х, натуральное число n. написать программу, которая вычисляет сумму последовательности, заданной формулы x^1/1! +x^2/2! +x^3/3! ++x^n/n! 2) разработать программу циклической структурой в соответствии с предложенным вариантом, используя цикл с предусловием. дано действительное число х, натуральное число n. написать программу, которая вычисляет сумму последовательности, заданной формулы x^1/1! +x^2/2! +x^3/3! ++x^n/n! 3)определить значение z = max (a, 2b) • max (2a-b, b),где max (x, y) есть максимальное из чисел х, у. при peшении определить и использовать функцию max.выполнить отладку программы с заходом в каждую из подпрограмм.

Ответ:
сафийка3
сафийка3
03.10.2020 18:34
//Pascal ABC.NET 3.1 сборка 1219

//1
Var
 n,i:integer;
 x,y:real;

 function fact(x:integer):int64;
 begin
  if x>1 then fact:=fact(x-1)*x else fact:=1;
 end;

 begin
 read(x,n);
 i:=1;
 n:=n+1;
 repeat
   y:=y+power(x,i)/fact(i);
   inc(i);
 until n=i;
writeln(y);
end.

//2
Var
 n,i:integer;
 x,y:real;
 function fact(x:integer):int64;
 begin
  if x>1 then fact:=fact(x-1)*x else fact:=1;
 end;

 begin
 read(x,n);
 i:=1;
 n:=n+1;
 while i<>n do
  begin
   y:=y+power(x,i)/fact(i);
   inc(i);
  end;
writeln(y);
end.

//3
Var
 a,b,z:integer;
 function max(a,b:integer):integer;
 begin
  if a>b then max:=a else max:=b;
 end;

 begin
 read(a,b);
 z:=max(a,2*b)*max(2*a-b,b);
 writeln(z);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?