В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ARTEMONUM
ARTEMONUM
27.08.2022 16:56 •  Информатика

Составьте программу заполнения массива из 100 целых чисел случайными числами от 1 до 20 и найти сумму четных чисел

Ответ:
3lJouKpolJouk
3lJouKpolJouk
25.08.2020 17:19
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
  var a:=ArrRandom(100,1,20); a.Println;
  Writeln('Сумма четных чисел равна ',a.Where(x->x.IsEven).Sum)
end.

Тестовое решение
7 9 17 2 1 18 8 9 9 3 14 13 10 18 20 5 5 9 5 18 20 12 6 19 2 3 20 17 9 15 3 2 18 17 16 8 5 11 7 15 19 11 17 15 18 18 12 17 12 11 11 11 15 9 20 16 3 19 1 18 18 12 1 14 20 12 16 14 2 13 1 15 3 11 19 9 16 12 2 4 12 3 5 19 4 12 7 10 17 1 5 7 11 9 17 7 11 3 16 6
Сумма четных чисел равна 528
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?