В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nastya02012007
nastya02012007
21.05.2022 17:12 •  Информатика

Pascal. дана строка из строчных букв. между соседними словами - запятая, за последним словом - точка. составить программу, печатающую в алфавитном порядке: 1. все гласные буквы, которые входят в каждое слово. 2. все согласные буквы, которые не входят ни в одно слово.

Ответ:
Roth999
Roth999
03.10.2020 18:26
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
function Гласные_в_слове(w:string):sequence of char;
begin
  Result:=w.ToCharArray.Where(c->Pos(c,'аеёиоуыэюя')>0).Distinct
end;

begin
  var s:=ReadlnString('>');
  var w:=s.ToWords(',','.');
  var P:=Гласные_в_слове(w[0]);
  for var i:=1 to Length(w,0)-1 do begin
    var Q:=Гласные_в_слове(w[i]);
    P:=P.InterSect(Q)
    end;
  P:=P.Sorted;
  if P.Count>0 then begin
    Write('Гласные, которые есть в каждом слове: ');
    P.Println(',')
    end
  else
    Writeln('Нет ни одной одинаковой гласной во всех словах');
  var R:='бвгджзйклмнпрстфхцчшщъь'.ToCharArray.ToList;
  foreach var c in s do
    if c in R then R.Remove(c);
  if R.Count>0 then begin
    Write('Согласные, которых нет ни в одном слове: ');
    R.Println(',')
    end
  else
    Writeln('Все согласные присутствуют в тексте')
end.

Тестовое решение
> фонарик,барахолка,биосфера,волокуша,макароны.
Гласные, которые есть в каждом слове: а,о
Согласные, которых нет ни в одном слове: г,д,ж,з,й,п,т,ц,ч,щ,ъ,ь
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?