В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mGgl1
mGgl1
24.02.2020 21:45 •  Информатика

Составьте программу вывода числа делителей натурального числа м в паскале abc

Ответ:
Krasnovadiana11
Krasnovadiana11
28.09.2020 13:59
Var m,d,kol:uint64;
begin
read(m);
for d:=1 to m do begin
   if (m mod d)=0 then inc(kol);
   end;
write(kol);
end. Это программа для делителей от 1 до m.

var m,d,kol:uint64;beginread(m);for d:=2 to m-1 do begin   if (m mod d)=0 then inc(kol);   end;write(kol);end. Эта программа для делителей от 2 до m-1.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?