В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kargina55
kargina55
02.05.2023 21:43 •  Информатика

Написать программу в паскаль. дан произвольный текст. преобразовать его по следующим правилам: все буквы «о» заменяются на «оа», все пробелы заменяются символом «_», а запятые удаляются.

Ответ:
zero407
zero407
03.10.2020 18:22
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
  var s:=ReadlnString('>');
  s:=s.Replace('о','oa').Replace(' ','_').Replace(',','');
  Writeln(s);
end.

Тестовое решение
> "Дает корова молоко" - писать, конечно, не легко!
"Дает_кoaрoaва_мoaлoaкoa"_-_писать_кoaнечнoa_не_легкoa!
0,0(0 оценок)
Ответ:
weee2004
weee2004
03.10.2020 18:22
S- переменная текста
i- счетчик
readln(s);
for i:= 1 to length(s) do
 begin
  if (s[i]='о') then
 s[i]:='оа';
    if  (s[i]=' ') then
(s[i]='_')
if (s[i]=',') then
 s[i]:='';
writeln(s);
end.
   Вроде как-то так
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?