В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ViolettaBazarova
ViolettaBazarova
31.05.2021 10:38 •  Информатика

Построить блок-схему алгоритма и написать программу для решения следующей . даны действительные числа x и y. если x и y отрицательны, то уаждое значение заменить его модулем; если отрицательно только одно из них, то оба значения увеличить на 0.5, в противном случае извлечь из каждого квадратный корень.

Ответ:
AraEv
AraEv
28.09.2020 13:05

var

x, y:real;

begin

readln(x, y);

if (x>0) and (y>0) then

begin

x:=sqrt(x);

y:=sqrt(y);

writeln(x,' ', y);

end;

if (x<0) and (y<0) then

begin

x:=x*(-1);

y:=y*(-1);

writeln(x,' ', y);

end;

if (x<0) or (y<0) then

begin

x:=x+0.5;

y:=y+0.5;

writeln(x,' ', y);

end;

end.


Построить блок-схему алгоритма и написать программу для решения следующей . даны действительные числ
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?