В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
никита20029
никита20029
28.03.2021 03:29 •  Информатика

Составить программу на паскале с цикла с неизвестным числом повторений. "на первый же день появления красавца васи в колледже в него влюблялись 2 девочки. с каждым днем их число увеличивалось в два раза, но каждую неделю 23 девочки разочаровывались в нем и влюблялись в сережу. через сколько дней в васю влюбятся 45 девочек? "

Ответ:
ktlwfh
ktlwfh
03.10.2020 18:17
Var k,n:integer;
begin
n:=1;
k:=2;
while k<=45 do
 begin
 n:=n+1;
 k:=k*2;
 if n mod 7 = 0 then k:=k-23;
 end;
writeln('n = ',n,' k = ',k);
end.

Результат:
n = 6 k = 64
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?