В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Иван54654
Иван54654
15.05.2020 09:11 •  Информатика

Составить блок-схему и написать программу на языке pascalabc.net. 1. даны действительные положительные числа x, y, z. выяснить, существует ли треугольник с длинами сторон x, y, z. 2. даны три действительных числа. выбрать из них те, которые принадлежат интервалу (1, 3).

Ответ:
annasefershaeva
annasefershaeva
28.09.2020 12:06
1. Треугольник будет существовать если будут выполнятся одновременно три неравенства:
x + y > z
x + z > y
y + z > x

Программа:

var x, y, z: real;
begin
  writeln('Введите стороны треугольника x, y, z: ');
  read(x, y, z);
  if (x + y > z) and (x + z > y) and (y + z > x) 
  then writeln('Треугольник существует')
  else writeln('Треугольник не существует');
end.

2. Думаю, здесь излишни объяснения.

Программа:

var x, y, z: real;
begin
  writeln('Введите три числа: ');
  read(x, y, z);
  writeln('В интервале (1; 3) лежат числа: ');
  if (x > 1) and (x < 3) then writeln(x);
  if (y > 1) and (y < 3) then writeln(y);
  if (z > 1) and (z < 3) then writeln(z);
end.

Блок-схемы в приложении:
Составить блок-схему и написать программу на языке pascalabc.net. 1. даны действительные положительн
Составить блок-схему и написать программу на языке pascalabc.net. 1. даны действительные положительн
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?