В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
pika4y2
pika4y2
05.01.2021 03:21 •  Информатика

Напишите программу, которая спрашивала бы сокращенное имя, а печатала полное для пяти ваших друзей. ввод незнакомого имени должен провоцировать заявление типа «я с вами незнакома

Ответ:
Djajdjo
Djajdjo
07.09.2020 23:19
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
begin
  var names:array[1..2,1..5] of string:=
    (('Саша','Женя','Таня','Лена','Вася'),
    ('Александр','Евгений','Татьяна','Елена','Василий'));
  var name:=ReadlnString('Введите краткое имя:');
  var p:=0;
  for var i:=1 to 5 do
    if name=names[1,i] then begin p:=i; break end;
  if p>0 then Writeln(names[2,p])
  else Writeln('Я вас не знаю!')
end.

Тестовое решение
Введите краткое имя: Лена
Елена
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?