В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
happymenfeed
happymenfeed
19.05.2020 11:30 •  Информатика

Написать программу в pascal. найти разность наибольшей и наименьшей цифр 3-х значного числа.

Ответ:
AndreyPulik
AndreyPulik
03.10.2020 17:51
Var a, b, c, r : integer;
begin
c:=0;
r:=9;
write('Введите число: ');
readln(a);
while a div 10 <> 0 do
begin
b:=a mod 10;
a:=a div 10;
if b>c then c:=b;
if b<r then r:=b;
end;
b:=a mod 10;
a:=a div 10;
if b>c then c:=b;
if b<r then r:=b;
writeln('Разность: ', c-r);
end.
ДА ХОТЬ ДЛЯ 10 ЗНАЧНОГО
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?