Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Ф
Физика
Э
Экономика
М
Математика
Г
География
И
Информатика
Ф
Французский язык
М
МХК
О
Окружающий мир
Н
Немецкий язык
П
Психология
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
А
Английский язык
Б
Биология
Қ
Қазақ тiлi
Показать больше
Показать меньше
Jack123456789
28.10.2021 20:33 •
Информатика
Составьте программу для решения одной из следующих , которая запрашивает значение элементов одномерного числового массива а и подсчета суммы элементов массива, меньших своего номера.
Ответ:
osipovalex1969
03.10.2020 17:29
//Pascal ABC.NET v3.1 сборка 1219
Const
n=5;
Var
a:array[1..n] of integer;
i,s:integer;
begin
for i:=1 to n do
begin
readln(a[i]);
if a[i]<i then s:=s+a[i];
end;
writeln(s);
end.
Пример ввода:
2
2
1
1
2
Пример вывода:
4
0,0
(0 оценок)
Популярные вопросы: Информатика
vmalina2005
07.05.2022 03:11
Для подключения процессора к оперативной памяти служит:...
Неизвестная66
17.08.2021 16:21
Как называется часть памяти компьютера в которую поподает скопированный и вырезанный фрагмент текста?...
dan4ik105217
18.11.2020 04:26
Составьте блок-схему и напишите программу вывода на экран а)5 первых четных натуральных чисел б) n первых натуральных чисел...
Dermo238
18.11.2020 04:26
Дано число. если даное число делится на 4 то разделить на 2 иначе оставить без изменение...
КсЮшЕнЬкА1102
28.11.2021 04:09
Сколько значащих нулей содержит число 2 в 25 степени...
likunya
13.06.2022 11:08
Как поставить пароль на сервер в teamspeak e...
averdarya
11.04.2021 20:30
Вычислите действия 4/51: 1 2/17 х57/64 помлгите контрольную дали на дом...
Ychi1ka
11.04.2021 20:30
10 предложений о казахстане на (легкие)...
Niker04
11.04.2021 20:30
Влияние факторов природы и растительные сообщества умоляю в...
kartofan2016p08uuy
11.04.2021 20:30
Подчеркните члены предложения обозначьте части речи дайте характеристику нарисуйте схему: живёт он в высокомосиннике и не прячется...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Const
n=5;
Var
a:array[1..n] of integer;
i,s:integer;
begin
for i:=1 to n do
begin
readln(a[i]);
if a[i]<i then s:=s+a[i];
end;
writeln(s);
end.
Пример ввода:
2
2
1
1
2
Пример вывода:
4