В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Turtle183119
Turtle183119
02.02.2023 07:44 •  Информатика

Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается нулем.(a=0 признак окончания ввода , ноль не входит в последовательность). программа должна вывести количество и сумму всех чисел последовательности.

Ответ:
irisha190784
irisha190784
03.10.2020 17:24
Var a, b, c: integer;
begin
b:=0;
c:=0;
readln(a);
while a <> 0 do
begin
b:=b+1;
c:=c+a;
readln(a);
end;
writeln('Кол-во: ',b);
writeln('Сумма: ',c);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?