В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Напишите программу, которая находит сумму четных чисел, больших 5, в последовательности целых чисел. программа получает на выход целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0( признак окончания ввода, не входит в последовательность). количество чисел не превышает 100. введенные числа по модулю не превышают 30000. программа должна вывести одно число: сумму чётных чисел, больше 5.

Ответ:
дизззи
дизззи
27.09.2020 20:46
Var
    a: integer;
    s: longint;

begin
    s := 0;
    readln(a);
    
    while a <> 0 do
    begin
        if (a mod 2 = 0) and (a > 5) then
            s := s + a;
        readln(a);
    end;
    
    writeln(s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?