Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Zheka1163
25.09.2022 17:57 •
Информатика
Дан массив из 20 натуральных чисел. составить программу суммы элементов, кратных данному числу d .
Ответ:
sadyk771
27.09.2020 20:21
Const
n=20;
var a:array[1..n] of integer;
var i,d,s:integer;
begin
s:=0;
writeln('Введите число d');
readln(d);
writeln('Введите массив');
for i:=1 to n do begin
read(a[i]);
if a[i] mod d = 0 then s:=s+a[i];
end;
writeln(s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
maiagolubeva5
06.07.2020 18:32
Создает гиперссылку на закладку, находящуюся в текущем документе...
Uprava
12.09.2021 09:13
Привет, привет, привет разобраться...
damiramirov321
14.05.2022 05:25
Составьте алгоритм действий для робота, который высаживает цветы на грядке....
maks200906
16.11.2021 18:32
Какое окончание глагола читается как (id) lived talked wanted walked какой глагол не является неправильным! take give fall talk...
Pomogu0pogalycta
16.11.2021 18:32
Какое прилагательное имеет нестандартную сравнительную форму и почему в кратциях happy bad hot kind найди глагол to be в past simple where were white we...
ГАЛЯ2006261011444
16.11.2021 18:32
Составь из этих слов предложение made/winter/a snowman/last/they...
alya5511Аля
16.11.2021 18:32
Основные сражения великой отечественной войны...
demorgan512
16.11.2021 18:32
Уровнять реакцию: cr2(so4)3+kmno4+h2so4=k2cr2o7+mnso4+k2so4+h2o...
sokolin2
16.11.2021 18:32
(5,12+x)*0,14=8,4 2,472: (30-y)=0,12 (x-4,7)*3,4=12,92 12,7-4,5x=8,29...
Бика2525
16.11.2021 18:32
Найти производную y = sqrt(sin3x - x^3)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
n=20;
var a:array[1..n] of integer;
var i,d,s:integer;
begin
s:=0;
writeln('Введите число d');
readln(d);
writeln('Введите массив');
for i:=1 to n do begin
read(a[i]);
if a[i] mod d = 0 then s:=s+a[i];
end;
writeln(s);
end.