Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
thebilryto0854
22.02.2023 14:08 •
Информатика
Задан массив k(n). и отрицательные элементы массива заменить на их квадраты. вывести их индексы и новые значения.
Ответ:
goooll
03.10.2020 17:15
Const
i=10;
var k:array[1..i] of integer;
n:integer;
begin
writeln('Введите элементы массива');
for n:=1 to i do begin
read(k[n]);
if k[n]<0 then k[n]:=sqr(k[n]);
end;
for n:=1 to i do write(k[n], ' ');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
JuliIs26
21.02.2021 18:13
Написать программу: Заполнить массив размерностью 15 целыми числами из промежутка от - 5 до...
Кактус1313
07.03.2022 08:34
X=10. Чому дорівнює y після виконання оператора? If x 0 Тhen y := x Else If x = 5 Then y := sqr(x) Else y := 2*x;...
znania53
10.03.2023 02:38
У исполнителя Вычислитель две команды, которым присвоены номера: 1 — прибавь 5; 2 — умножь на 3.Первая из них увеличивает число на 5, вторая увеличивает в 3 раза....
andreylishtaev
11.08.2020 12:02
Ссылка на файл: https://yadi.sk/i/sC1AerOx2M9XbQ...
anastasiasestak
11.08.2020 12:02
. Как записать формулу в Excel - из 100 - сумму всех ячеек? Подсчитайте долю прочих расходов бюджета, если вся сумма расходов составляет 100%. Данные в таблице на...
Olzhas2889
10.05.2022 20:22
Укажите верное соотношение для множеств А={5, 9, 11), В={4, 5, 10, 11,12}, C={4, 5, 9, 11). Варианты ответов : AcB Всс Асс СcB...
svitlanakost
09.02.2023 13:26
Как задать во на знания.com?...
ритуа
07.12.2021 18:16
Какая команда пропущена в данном участке программы, отвечающем за поиск максимального элемента массива. Запишите команду без пробелов. r:=1; for i:=2 to n do if a[i]...
Feraaa2108
14.08.2021 16:04
В описании переменных после имени массива ставится знак: 1) ; 2) : 3) =...
msa234
20.07.2020 23:13
ТОЛЬКО первый номер 8 Класс...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
i=10;
var k:array[1..i] of integer;
n:integer;
begin
writeln('Введите элементы массива');
for n:=1 to i do begin
read(k[n]);
if k[n]<0 then k[n]:=sqr(k[n]);
end;
for n:=1 to i do write(k[n], ' ');
end.