В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
228795111
228795111
27.06.2022 05:50 •  Информатика

Написать программу используя процедуру которая сортирует элементы целочисленного массива b[1..n],n меньше или равно 25 по убыванию

Ответ:
DanilOtlicnic
DanilOtlicnic
27.09.2020 19:18
Class Sort25{
 public static void main(String[] args) throws java.io.IOException{
  int c, n = 0, array[];
  while((c = System.in.read())==13 || (47<c && c<58 && (n = n*10+c-48)>-1));
  if(25<n || c!=10)return;
  array = new int[n];
  for(c = 0; c<n; c++){
   int d = 0; boolean negative = false;
   while((d = System.in.read())!=10)
    if(47<d && d<58)array[c] = array[c]*10+d-48;
    else if(d==45)negative = true;
   if(negative)array[c]*=-1;
  }
  sortArray(array);
  for(c = 0; c<n; c++)System.out.print(array[c]+" ");
 }
 private static void sortArray(int[] array){
  for(int c = 0; c<array.length-1; c++){
   int b = c, e;
   for(int d = c+1; d<array.length; d++)
    if(array[d]>array[b])b=d;
   e = array[c];
   array[c] = array[b];
   array[b] = e;
  }
 }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?