В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
svetik040201p01o4x
svetik040201p01o4x
13.05.2022 19:40 •  Информатика

Напишите программу,которая в последовательности натуральных чисел определяет наибольшее число ,кратное 3и оканчивающееся на 6.программа получает на вход количество чисел в последовательности ,а затем сами числа.в последовательности всегда имеется число кратное 3 и оканчивающееся на 6. количество чисел не превышает 1000.введенные числа не превышают 30000. программа должна вывести одно число : наибольшее число,кратное 3 и оканчивающееся на 6.входные данные: 5,18,126,165,36,135.выходные данные: 126

Ответ:
kiramillerthe1
kiramillerthe1
27.09.2020 15:01
Var max,n,x:integer; 
begin 
writeln('Введите количество цифр'); 
read(n); 
max:=0; 
repeat 
writeln('Введите число. (Осталось ввести ',n, ')'); 
readln(x); 
if (x mod 3=0) and (x mod 10=6) and (abs(x)>max) then max:=x; 
n:=n-1; 
until n=0; 
writeln('Максимальное число, кратное 3-м и заканчивающееся на 6 = ',max); 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?