Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Ф
Физика
Э
Экономика
М
Математика
Г
География
И
Информатика
Ф
Французский язык
М
МХК
О
Окружающий мир
Н
Немецкий язык
П
Психология
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
А
Английский язык
Б
Биология
Қ
Қазақ тiлi
Показать больше
Показать меньше
radion2005
31.05.2021 05:12 •
Информатика
Паскаль для решения следующей : заполнить целочисленный массив 20-ю случайными элементами в диапазоне от 20 до 40 и найти сумму лишь нечётных номеров (элементов) массива.
Ответ:
василиска8
03.10.2020 16:55
Const
n = 20;
var
a: array[1..n] of integer;
i, s: integer;
begin
randomize;
for i := 1 to n do
begin
a[i] := random(20) + 20;
write(a[i], ' ');
if i mod 2 = 1 then
s := s + a[i];
end;
writeln();
writeln(s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Сашенькадельфинчик
04.11.2021 08:19
Велосипедисты Два велосипедиста выехали одновременно из пункта A по одной дороге с различными скоростями uu и vv метров в секунду. Через tt секунд им вдогонку выехал...
AnyaAnokhina214
14.09.2022 04:38
Дана последовательность действительных чисел а1, а2, а3...аn Cоздать массив из положительных чисел этой последовательности (если таких чисел нет, то вывести сообщение...
arinuhkas
28.03.2023 10:28
Комп’ютер і відповідне програмне забезпечення, за до якого підтримується робота електронної пошти -інтернет -комп ютерна мережа -комп ютер -поштовий сервер...
coolpetrov
17.03.2021 01:59
Какое условие записано верно для определения четности переменной а a mod 2 = 0 a mod 2 = 1 a div 2 = 0 a div 2 = 1...
Осоаовлво
17.03.2021 01:59
Какой объём видеопамяти необходим для хранения четырёх страниц изображения,при условии,разрешающая дисплея равна 640х480 точек,а используемых-32?...
SevenDays7
28.08.2021 02:59
Как создать алгоритм по угадыванию числа в диапазоне от 1 до 8?...
sveta998
31.08.2020 18:57
Напишите программу, которая по заданному натуральному n печатает первые n чисел последовательности 1, 2, 4, 8, 16, 32. в первой строке содержится n (1 ≤ n ≤ 50)...
kononovadm
18.09.2020 16:40
Практическая часть Задание 1. Запишите результат выполнения арифметических операций1) 19 div 8 =2) 20 div 5 = 3) 18 div 4 =4) 837 div 100 =5) 3974 div 1000 =6)...
alenamorozova4
01.11.2021 03:14
Где происходит яйцо печёночного сосальщика?...
Gogasg
16.02.2022 08:35
Чем отличается внутренняя культура от внешней?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
n = 20;
var
a: array[1..n] of integer;
i, s: integer;
begin
randomize;
for i := 1 to n do
begin
a[i] := random(20) + 20;
write(a[i], ' ');
if i mod 2 = 1 then
s := s + a[i];
end;
writeln();
writeln(s);
end.