В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Мама1мама2
Мама1мама2
06.02.2020 05:53 •  Информатика

Нужно решение буду завтра итоговая контрольная: дан массив чисел d[i],в котором 7 элементов.найти сумму четных элементов массива,и вычеслить среднее арифметическое всех элементов массива. буду признателен, пишем на паскале, если можно напишите программу, или скиньте скрин! жду

Ответ:
markinaalisa2003
markinaalisa2003
27.09.2020 14:24
Const
n = 7;
var a: array [1..n] of integer; i, m0, m1: integer;
 begin
  m0:=0; m1:=0;
  writeln('Массив -->');
  for i:= 1 to n do readln(a[i]);
   for i:= 1 to n do begin
    m0:=m0+a[i];
    if a[i] mod 2 = 0 then m1:= m1+a[i];
  end;
 writeln('Cумма четных элементов массива: ',m1);
 writeln('Cреднее арифметическое всех элементов массива: ',m0/n);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?