В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
CleverBoy17
CleverBoy17
01.06.2023 20:53 •  Информатика

Написать программу для pascal. вычислите сумму положительных и кол-во отрицательных чисел на отрезке, концы которого вводятся с клавиатуры.

Ответ:
kantuz
kantuz
03.10.2020 16:50
Var a,b,k1,k2,s:integer; 
begin 
s:=0; 
k1:=0; 
writeln('Введите начало и конец отрезка'); 
read(a,b); 
k2:=b-a+1; 
repeat 
if b<0 then break; 
s:=s+b; 
b:=b-1; 
inc(k1); 
until (b=-1) or (b=a-1); 
writeln('Сумма всех целых положительных чисел на отрезке = ',s); 
writeln('Количество отрицательных целых чисел = ', k2-k1); 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?