В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
DarkZlo
DarkZlo
26.08.2020 01:24 •  Информатика

Синформатикой. pascal abc. 25 блоха и куб. блоха находится в вершине куба. за один прыжок она может переместиться в любую соседнюю вершину. сколькими различными путями она ровно за n прыжков может оказаться в противоположной вершине? нужно написать программу для pascal !

Ответ:
akowa05
akowa05
03.10.2020 16:50
Представим куб в виде графа его каркаса. Пронумеруем все вершины куба цифрами от 1 до 8. Задача сводится к обычному обходу в ширину. Для четных N ответ будет 0, т.к. нельзя дойти на противоположную вершину за четное кол-во шагов. ответ будет расти в геометрической прогрессии в зависимости от N. Программа:

const
  m: array[1..8, 1..8] of byte = 
 ((0, 1, 1, 1, 0, 0, 0, 0),
  (1, 0, 0, 0, 1, 0, 1, 0),
  (1, 0, 0, 0, 1, 1, 0, 0),
  (1, 0, 0, 0, 0, 1, 1, 0),
  (0, 1, 1, 0, 0, 0, 0, 1),
  (0, 0, 1, 1, 0, 0, 0, 1),
  (0, 1, 0, 1, 0, 0, 0, 1),
  (0, 0, 0, 0, 1, 1, 1, 0));
  
var
  n, i, j, k: integer;
  a: array[0..100, 1..8] of int64;
begin
  read(n);
  a[0, 1] := 1;
  for k := 1 to n do
    for i := 1 to 8 do
      for j := 1 to 8 do
        if m[i, j] = 1 then
          a[k, i] := a[k, i] + a[k - 1, j];
  write(a[n, 8]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?