В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
adilete840
adilete840
04.02.2021 17:37 •  Информатика

Напишите программу в паскале abc, которую вводим последовательность целых чисел заканчивающуюся нулем и определяет верно ли что введеные элементы чередуют знаки, например (2, -2, 3, -3, 4, -4, 5, -5: да знаки чередуются) не используя масивов. либо объясните алгоритм действий

Ответ:
annaegorova4
annaegorova4
31.08.2020 01:39
Program lol(input, output); var b, a, a1:integer; begin a:=1; b:=0; a1:=-1; repeat begin read (a); if (a/((-1)*a))=(a1/a1) then b:=b+1; if a=0 then break; read (a1); if a <> (-1)*a1 then b:=b+1; end until (a=0) or (a1=0); if b>1 then writeln ('Последовательность не верна') else writeln ('Последовательность верна'); end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?