В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Кириииил
Кириииил
27.06.2021 08:20 •  Информатика

по информатике нужно написать программу. " пользователь вводит текст. посчитать количество предложений и слов в этом тексте." program go; var s1: string; a,i,k,b: integer; begin writeln('введите текст'); begin; readln(s1); a: =length(s1); if a> 0 then begin b: =1; while a> 0 do begin if s1[i]='b' then b: =b+1; i: =i-1; end; end else b: =0; writeln('количество слов в тексте',b); end; begin; readln(s1); a: =length(s1); for i: =1 to a do if s1[i]='.' then if s1[i+1]=' ' then k: =k+1; end; writeln('в тексте ',k,' предложений..'); end. при выполнени и моей выдает ошибку выполнения времени. индекс находится вне границ массива..

Ответ:
DendiYT
DendiYT
07.08.2020 16:50
Var   s: string;
        i,k,c: integer;
begin       
write('Введите текст: ');
        readln(s);
        i := length(s);
        k:=0;
        for i:=1 to length(s) do
        if s[i] in ['.','?','!'] then inc(k);
        if i > 0 then begin
        c := 1;
        while i > 0 do begin
        if s[i] = ' ' then
        inc(c);
        dec(i);
        end;
        end
        else
        c := 0;
        writeln('Количество слов в тексте: ', c);
        writeln('Количество предложений в тексте: ', k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?