В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mebelru
mebelru
28.01.2023 00:36 •  Информатика

Напишите программу на языке программирования (или составьте алгоритм). заполнить массив в, состоящий из сорока элементов, случайными целыми числами из интервала [–30; 50] и найти максимальный элемент.

Ответ:
romanvailev15
romanvailev15
25.09.2020 22:15
 var i,max:integer;
      b:array[1..40] of integer;
begin
  randomize;
  for i:=1 to 40 do
     begin
      b[i]:=random(random(80))-30;
      write(b[i],' ');
    end;
    writeln;
    max:=b[1];
  for i:=1 to 40 do
     begin
      if b[i]>= max then
        begin
          max:=b[i];
         end;
    end;
  writeln('Максимальный элемент массива: ',max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?