Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
masloshick
28.09.2021 06:09 •
Информатика
Напишите программу на языке pascal печатающую все отрицательные нечетные числа, начиная с числа n (n< -100) , в обратном порядке. , , нужна ваша !
Ответ:
Gkdm
03.10.2020 15:44
1. Короткий вариант
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
Range(-99,-1,2).Print
end.
Результат
-99 -97 -95 -93 -91 -89 -87 -85 -83 -81 -79 -77 -75 -73 -71 -69 -67 -65 -63 -61 -59 -57 -55 -53 -51 -49 -47 -45 -43 -41 -39 -37 -35 -33 -31 -29 -27 -25 -23 -21 -19 -17 -15 -13 -11 -9 -7 -5 -3 -1
2. Школьный вариант
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
var
i:integer;
begin
i:=-99;
repeat
Write(i,' ');
i:=i+2
until i>-1
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
ksu1976reg
20.12.2022 18:59
Сопераций вырезки и соединения составить из слова «фывапролджэ» любые 4 слова....
katyakot56806
19.10.2020 11:32
Выберите из списка устройства ввода, позязя. 1. наушники 2. мышь 3. флеш-накопитель 4. микрофон 5. монитор 6. веб-камера 7. трекбол 8. клавиатура 9. сканер 10. принтер 11. процессор...
covik332
05.03.2023 20:02
Вася ошибся, когда писал программу, и теперь она выводит бесконечную последовательность + | + | + | … Выведи только её первые 99 символов....
еккаа
06.04.2023 07:38
компьютер Windows 10 как можно сбросить все настройки компьютера но оставить все фотографии и прочее остальное...
gasdgg
18.09.2020 19:37
Графический редактор Выберите формат растрового изображения. .pdf .jpg .mp3 .exe...
соня1584
03.01.2021 07:55
Я не разбираюсь, что делать если:...
юра417
06.07.2022 10:35
Напишите программу, которая вводит с клавиатуры одномерный массив из 5 целых чисел и выводит на экран количество ненулевых элементов. Перед вводом каждого элемента на экране...
juliadzyombak
16.03.2021 21:13
Мистер Фокс научился переводить числа из десятичной системы счисления в двоичную. Ему это так понравилось, что он занимался целый день и не устал. Предлагаем повторить подвиг...
robka2029
29.03.2023 15:08
Запишите внутреннее представление десятичного числа 44 в 8 разрядной ячейки памяти компьютера...
Karinakotik200165
30.12.2022 01:50
Монография, набранная на компьютере, содержит 2048 страниц, на каждой странице 48 строк, в каждой строке 72 символа. Для кодирования символов используется кодировка Unicode,...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
Range(-99,-1,2).Print
end.
Результат
-99 -97 -95 -93 -91 -89 -87 -85 -83 -81 -79 -77 -75 -73 -71 -69 -67 -65 -63 -61 -59 -57 -55 -53 -51 -49 -47 -45 -43 -41 -39 -37 -35 -33 -31 -29 -27 -25 -23 -21 -19 -17 -15 -13 -11 -9 -7 -5 -3 -1
2. Школьный вариант
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
var
i:integer;
begin
i:=-99;
repeat
Write(i,' ');
i:=i+2
until i>-1
end.