Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
NastyaKoryak
27.04.2023 03:56 •
Информатика
Составить программу.сформировать одномерный массив n=10 a[i]=i^3 1 8 найти сумму 1-го,5-го и последнего элемента.
Ответ:
gusakova2016poly
03.10.2020 15:35
Const
n = 10;
var
a: array[1..n] of integer;
i: integer;
begin
for i := 1 to n do
a[i] := i * i * i;
writeln(a[1] + a[5] + a[n]);
end.
0,0
(0 оценок)
Ответ:
Словарь11
03.10.2020 15:35
1. Короткий вариант
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
var a:=1.To(10).Select(x->x*x*x).ToArray; a.Println;
Writeln('s=',a[0]+a[4]+a[9])
end.
Результат
1 8 27 64 125 216 343 512 729 1000
s=1126
2. Школьный вариант
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
var
i:integer;
a:array[1..10] of integer;
begin
for i:=1 to 10 do begin
a[i]:=i*i*i;
Write(a[i],' ')
end;
Writeln;
Writeln('s=',a[1]+a[5]+a[10])
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Кошка022
15.12.2020 21:47
Построить график функций y=2sin(x/3) на отрезке [3,14; 25,12] с шагом 0,9 в программе ms excel...
senab
16.08.2022 13:09
Что обозначено цифрой 5?Панель инструментовОсновное полеСтрока состоянияСтрока меню...
zirkakoi
25.10.2022 09:32
2. отметьте элементы окна приложения microsoft word. * название приложения; 1строка меню; 2 кнопка закрыть; 3кнопка свернуть; 4 панель инструментов; 5палитра; 6 панель стандартная;...
ассасин32
29.07.2022 16:39
1.для стоянки машин выделили площадку прямоугольной формы , примыкающую одной стороной к стене здания. площадку обнесли с трех сторон металлической сеткой длиной 200 м, и площадь...
lubenkovalilia2
29.07.2022 16:39
Ужителя села недесятичное в саду имеются 122 плодовых деревьев,из них 53 груши и 25 яблонь; и 112 кустов крыжовника и 15 кустов смородины.систему счисления, с каким основание...
t22422
29.07.2022 16:39
Какие числа стоят между числами -5 и 5 . напиши. сравни поставвь знаки = если x равняется 8. -2+x 3+5 x-9 -2 4-x. -3...
alesaastudinap0dbun
29.07.2022 16:39
3.из круглого бревна вырезают с прямоугольным сечением наибольшей площадки. найти размеры сечения . если радиус сечения бревна равен 20....
пацанизшараги
27.06.2020 19:41
645. Найдите площадь фигур на основании данных на рис. 10. б) 10) а) 3 дм 3 дм и 4 дм 4 дм 6 дм 3 дм 2 дм...
МаркЛеткеман
15.01.2020 06:22
Принадлежит ли графику функции у=х2+2 точки: 1) A (0; 2); 2) B (-1; 1); 3) C (-2; 6); 4) D (-3; -7)?...
ssssss22
15.01.2020 06:22
3. Найдите площадь фигуры, ограниченной линиями: п y = sinx, y = 0, x = 0, x = п на 3...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
n = 10;
var
a: array[1..n] of integer;
i: integer;
begin
for i := 1 to n do
a[i] := i * i * i;
writeln(a[1] + a[5] + a[n]);
end.
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
var a:=1.To(10).Select(x->x*x*x).ToArray; a.Println;
Writeln('s=',a[0]+a[4]+a[9])
end.
Результат
1 8 27 64 125 216 343 512 729 1000
s=1126
2. Школьный вариант
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
var
i:integer;
a:array[1..10] of integer;
begin
for i:=1 to 10 do begin
a[i]:=i*i*i;
Write(a[i],' ')
end;
Writeln;
Writeln('s=',a[1]+a[5]+a[10])
end.