В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
pipar93
pipar93
25.06.2020 15:28 •  Информатика

Составьте программу замены нулевых элементов таблицы единицами контрольный пример n=5 данные : (0,5,0,60,0) результат : (1,5,1,60,1)

Ответ:
Учительнотупой
Учительнотупой
03.10.2020 15:10
Язык Pascal, работа на массиве. с заполнением с клавиатуры. Ты заполняешь 5 элементов ( через enter ), а он тебе выводит тоже самое, только с однерками вместо нулей.

Var x: array[1..5] of integer;
Var i,h:integer;
Begin
for i:= 1 to 5 do
Begin;
Readln(h);
if (h=0) then x[i]:=1 else x[i] = h;
end;
for i:=1 to 5 do
Begin;
Writeln('Элемент номер ',i,' массива: ',x[i]);
end;
readln(x);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?