В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Аліна202
Аліна202
16.03.2020 03:59 •  Информатика

Составить программу на паскале, использовать неравенства x^2 + y^2 < = r^2 если точка принадлежит кругу и x^2 + y^2 > r^2 в противном случае

Ответ:
olya0091184
olya0091184
03.10.2020 14:48
Var x, y, x1, y1, r: real;
begin
write('Введите координаты точки X, Y: ');
read(x, y);
write('Введите координаты центра окружности X, Y: ');
read(x1, y1);
write('Введите радиус окружности R: ');
read(r);
if sqr(x-x1) + sqr(y-y1) <= r*r then writeln('Точка принадлежит кругу')
else writeln('Точка не принадлежит кругу')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?