В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nastyasuhomlinova
nastyasuhomlinova
07.05.2023 20:13 •  Информатика

Решить кто знает паскаль вот дан файл с оценками .txt учащихся написать программу которая определяет количество пятерок, четвёрок, троек. вывести их количество на экран. нужно написать в текстовом документе а с паскаля это прочитать

Ответ:
svetlana1968bup0c083
svetlana1968bup0c083
03.10.2020 14:43
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
  var a:=ReadallLines('in.txt')[0].ToIntegers;
  Writeln('Исходный набор отметок'); a.Println;
  var k3:=a.Where(x->x=3).Count;
  var k4:=a.Where(x->x=4).Count;
  var k5:=a.Where(x->x=5).Count;
  Writeln('Троек- ',k3,', четверок- ',k4,', пятерок-',k5)
end.

Тестовое решение
Исходный набор отметок
3 4 4 5 5 3 4 4 5 4 3 5 5 3 5 3 4 3 3 4 5 4 4 3 4 4 3 4 5 4
Троек- 9, четверок- 13, пятерок-8

Файл с отметками in.txt дан во вложении.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?