В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
rrrrrrrraaaaa
rrrrrrrraaaaa
04.08.2020 23:45 •  Информатика

Решите 1) дан текст .написать программу вставляющию после каждой запятой по одному пробелу. 2)дан текст ,слова в тексте разделены одним и несколькими пробелами.написатт программу выводящию все слова в алфавитном порядке.

Ответ:
Katya270403
Katya270403
30.08.2020 23:57
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
  var s:=ReadlnString('>');
  s:=s.Replace(',',', '); Writeln(s);
  Writeln(NewLine,'Список слов:');
  s.ToWords.OrderBy(x->x).Println(NewLine);
end.

Тестовый пример
> Это   мой,плохо форматированный,но зато мой текст!
Это   мой, плохо форматированный, но зато мой текст!

Список слов:
зато
мой
мой,
но
плохо
текст!
форматированный,
Это
0,0(0 оценок)
Ответ:
060609
060609
30.08.2020 23:57
//Pascal ABC.NET v3.1 сборка 1172

//1

Var
 s:string;
 i:integer;
begin
 readln(s);
 while i<length(s) do
 begin
 inc(i);
 if s[i]=',' then insert(' ',s,i+1);
 end;
 writeln(s);
end.

Пример ввода:
Some,awesome,test,text,
Пример вывода:
Some, awesome, test, text, 

//2

Var
 s:string;
 i,k,j:integer;
 ars:array of string;
begin
 readln(s);
 setlength(ars,length(s));
 k:=0;
 for i:=1 to length(s) do
 begin
  if (s[i]=' ') and (s[i+1]<>' ') and (i<>length(s)) then inc(k) else  ars[k]:=ars[k]+s[i];
 end;
 for i:=0 to k-1 do
  for j:=i+1 to k do
   if LowerCase(ars[i])>LowerCase(ars[j]) then
   begin
    s:=ars[i];
    ars[i]:=ars[j];
    ars[j]:=s;
   end;
 for i:=0 to k do
 writeln(ars[i]);
 end.

Пример ввода:
Очень              много яков и антилоп
Пример вывода:
антилоп
и
много
Очень
яков
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?