В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Нужно составить программу в паскаль. 1. в массиве 10 чисел. положительные числа замените их номерами. вывести на экран в столбик изменившийся массив. 2. в массиве м(8) найдите сумму элементов, больших 12

Ответ:
milanalive65
milanalive65
13.08.2020 23:26
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
  Writeln('-'*10);
  var a:=ArrRandom(10,-99,99); a.Println;
  a:=a.Select((x,i)->x>0?i+1:x).ToArray; a.Println(NewLine);
  Writeln('-'*10);
  var m:=ArrRandom(8,-10,30); m.Println;
  Writeln('s=',m.Where(x->x>12).Sum)
end.

Тестовое решение

26 -63 12 85 9 53 57 36 -45 30
1
-63
3
4
5
6
7
8
-45
10

11 -4 14 6 24 0 -8 10
s=38
0,0(0 оценок)
Ответ:
sharamat2001
sharamat2001
13.08.2020 23:26
Файл в приложении
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?